1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Saturn Configuration Utility

Discussion in 'FPGA Boards' started by Richard Myers, May 11, 2015.

  1. Richard Myers

    Richard Myers New Member

    Joined:
    Feb 27, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Occupation:
    Consulting Engineer
    Location:
    Grass Valley, CA, USA
    Hi,

    We are experiencing problems with configuring the Saturn boards on 3 of 5 PCs. I believe it may affect PCs with USB3.0 HW and Windows 7 or below. I've pointed affected users to the beta configuration utility that does not use libMPSSE.dll mentioned in another thread to see if that helps.

    I'm wondering when the changes suggested by Gabor in a previous thread (on this forum) will be rolled into the configuration utility provided in the 'Downloads' section of the Saturn Description on the website.

    If the faster configuration utility (w/o libMPSSE.dll) has trouble, then could you make the suggested fix to the older utility as a stopgap measure until you figure out why the beta is not fully reliable?

    Thanks,

    Richard
     
  2. admin

    admin Administrator Staff Member

    Joined:
    Jan 23, 2015
    Messages:
    169
    Likes Received:
    10
    Trophy Points:
    18
    Hello Richard,

    I had shared a new utility that doesn't use libMPSSE.dll with you a week ago and never heard again! Can you please confirm if that helped? The unfortunate situation here is that the old utility and the new utility just works fine all our PCs (almost two dozens of them). This is actually stopping us from reproducing the issue onsite, which is a very important prerequisite for fixing it.

    Thanks,
    Tom
     
  3. Richard Myers

    Richard Myers New Member

    Joined:
    Feb 27, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Occupation:
    Consulting Engineer
    Location:
    Grass Valley, CA, USA
    Really? How odd! I didn't get it, but I just today added Numato to our email system whitelist, so hopefully I won't miss any more.

    Thank you!

    One user has verified today that the beta worked for him, and that it's much faster. The other guy is in Taiwan and I haven't heard back yet.

    Thanks,
    Richard

     
  4. admin

    admin Administrator Staff Member

    Joined:
    Jan 23, 2015
    Messages:
    169
    Likes Received:
    10
    Trophy Points:
    18
    Thanks Richard for confirming that the new tool worked for at least one user. This certainly is exciting news. Please let me know if it works for the rest of the people too. Once it works for everyone, we will officially replace the old tool with the new one on the product page.

    On some of our machines, the new tool used to fail occasionally. We will debug that in the meantime.

    Thanks,
    Tom
     
  5. Richard Myers

    Richard Myers New Member

    Joined:
    Feb 27, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Occupation:
    Consulting Engineer
    Location:
    Grass Valley, CA, USA
    Hi,

    Our user in Taiwan reports that the utility works, but does not show that it found a device. I guess you have to use something other than the location ID to tell whether a device is present ...

    upload_2015-5-12_9-29-54.png

    But for another user (nothing was detected with the old program):
    upload_2015-5-12_9-51-58.png

    Thanks,

    Richard
     
  6. admin

    admin Administrator Staff Member

    Joined:
    Jan 23, 2015
    Messages:
    169
    Likes Received:
    10
    Trophy Points:
    18
    Hello Richard,

    I will PM you with a link to a debug version of the tool in next couple of days. This tool will dump a bunch debug of info to a file which we can take a look at and find out what is happening.

    Thanks,
    Tom
     
  7. Richard Myers

    Richard Myers New Member

    Joined:
    Feb 27, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Occupation:
    Consulting Engineer
    Location:
    Grass Valley, CA, USA
    OK, I will await your email.

    Thank you
    Richard
     
  8. admin

    admin Administrator Staff Member

    Joined:
    Jan 23, 2015
    Messages:
    169
    Likes Received:
    10
    Trophy Points:
    18
    Hi Richard,

    Just shared the debug tool through a PM. Please download the same and give a try.

    Thanks,
    Tom
     
  9. Andrey

    Andrey New Member

    Joined:
    Aug 11, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    USA
    I know this issue was resolved.
    I am experience the same now.
    Is it possible to get the version of the tool which resolved an issue?
    Thanks
    Andrey
     
  10. rohith

    rohith Moderator Staff Member

    Joined:
    Mar 3, 2016
    Messages:
    54
    Likes Received:
    9
    Trophy Points:
    8
    Gender:
    Male
    Location:
    Bangalore
    @Andrey,

    Can you please raise a ticket by mailing at [email protected] ? It will get to our support staff and they will help you.

    Thanks!
     

Share This Page