1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Linux on Artix with MicroBlaze. MC package problem.

Discussion in 'FPGA Boards' started by ululuk, Dec 28, 2016.

  1. ululuk

    ululuk New Member

    Joined:
    Dec 28, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    MSK
    Hello!

    Thank you for such a detailed guide -
    https://docs.numato.com/kb/neso-microblaze-linux-run-linux-neso-artix-7-fpga-module/
    It's very simple and very very useful nevertheless!
    Now I can run Linux on my board with Artix 7 FPGA!

    In next step I'm tried to add some package to Linux image.
    And I was not able to run Midnight Commander (MC) package.
    Could you help me a little ?

    First of all I used these config files:
    https://raw.githubusercontent.com/numato/samplecode/master/FPGA/neso/nesoLinux-BSP/neso_defconfig
    https://raw.githubusercontent.com/n...FPGA/neso/nesoLinux-BSP/numato_neso_defconfig

    Then I added via "make menuconfig" these packages:
    nano
    mc
    strace
    ncurces (was added automatically with nano/mc)

    After "make" Linux image became larger (from 6 MB to 12 MB).
    I successfully uploaded it and run on Microblaze.
    Nano text editor works fine!
    But MC hangs.
    Here is traces of both packages (nano and mc): files is attached.
    There are some errors in log_mc.txt like this:
    0.002280 set_robust_list(0x4839d070, 12) = -1 ENOSYS (Function not implemented)
    0.002795 futex(0x481cfb34, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 ENOSYS (Function not implemented)

    Could you help me ? Is something (some options) wrong or missing in linux kernel config for midnight commander editor ?
    Is it possible to run it (mc) on embedded linux at all ?

    Thanks a lot!
     

    Attached Files:

  2. rohith

    rohith Moderator Staff Member

    Joined:
    Mar 3, 2016
    Messages:
    28
    Likes Received:
    3
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Bangalore
    Hello ululuk!

    Unfortunately, I do not have much expertise in Linux Kernel. But looking at the errors, it seems like both "set_robust_list" and "futex" functions are related to Futexes and it may be possible that Futexes are not enabled (either not supported in microblaze or simply just not enabled). I searched on the internet and it looks like there is a "CONFIG_FUTEX=y" configuration switch available to enable futexes. Can you please give it a try, and see if it helps?

    PS: I can see from the default Neso defconfig that futexes are not enabled there. There is this line in the file -> "# CONFIG_FUTEX is not set". So it may be worthwhile to give the above option a try.

    Thanks!
    Rohit
     
  3. ululuk

    ululuk New Member

    Joined:
    Dec 28, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    MSK
    Hi!

    Based on your recommendation I recreated buildroot with CONFIG_FUTEX option enabled.
    MC package again can not run successfully (
    Strace log file is attached.

    Is it possible that microblaze isn't support FUTEX option ?

    Thanks a lot!
     

    Attached Files:

  4. rohith

    rohith Moderator Staff Member

    Joined:
    Mar 3, 2016
    Messages:
    28
    Likes Received:
    3
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Bangalore
    Hello ululuk!

    Unfortunately I don't have more expertise on this matter. It might be the case that microblaze doesn't support FUTEXes at all. I would recommend asking this in Xilinx forums.

    Thanks!
    Rohit
     

Share This Page